Index A | B | C | D | E | F | G | H | I | K | L | M | N | O | P | R | S | T | U | V A adapter append_entry() (calendaring_sync.store.base.StateStore method) Applied (class in calendaring_sync.objects.push) at (calendaring_sync.objects.feed.FeedEntry attribute) B BOTH_CHANGED (calendaring_sync.objects.conflict.ConflictKind attribute) BOTH_CREATED (calendaring_sync.objects.conflict.ConflictKind attribute) C calendaring_sync.constants module calendaring_sync.error module calendaring_sync.objects.change module calendaring_sync.objects.change_set module calendaring_sync.objects.conflict module calendaring_sync.objects.dropped_scope module calendaring_sync.objects.edit module calendaring_sync.objects.feed module calendaring_sync.objects.push module calendaring_sync.objects.record module calendaring_sync.objects.resolution module calendaring_sync.objects.scope module calendaring_sync.replica module calendaring_sync.store.base module calendaring_sync.store.memory module calendaring_sync.store.sqlite module CalendaringSyncError CHANGE (calendaring_sync.objects.edit.EditKind attribute) Change (in module calendaring_sync.objects.change) change feed change set change() (calendaring_sync.replica.Replica method) CHANGED (calendaring_sync.objects.feed.FeedEntryKind attribute) Changed (class in calendaring_sync.objects.change) changes (calendaring_sync.objects.change_set.ChangeSet attribute) ChangeSet (class in calendaring_sync.objects.change_set) checkpoint claim claim() (calendaring_sync.replica.Session method) claims (calendaring_sync.objects.record.Record attribute) close() (calendaring_sync.store.base.StateStore method) conflict (calendaring_sync.objects.record.Record attribute) CONFLICT (calendaring_sync.objects.record.RecordState attribute) Conflict (class in calendaring_sync.objects.conflict) conflict record CONFLICT_OPENED (calendaring_sync.objects.feed.FeedEntryKind attribute) CONFLICT_RESOLVED (calendaring_sync.objects.feed.FeedEntryKind attribute) CONFLICT_UPDATED (calendaring_sync.objects.feed.FeedEntryKind attribute) ConflictKind (class in calendaring_sync.objects.conflict) conflicts (calendaring_sync.objects.dropped_scope.DroppedScope attribute) container containers (calendaring_sync.objects.change.Changed attribute) (calendaring_sync.objects.edit.LocalEdit attribute) (calendaring_sync.objects.record.Record attribute) (calendaring_sync.objects.resolution.Merge attribute) content (calendaring_sync.objects.change.Changed attribute) (calendaring_sync.objects.edit.LocalEdit attribute) (calendaring_sync.objects.record.Record attribute) (calendaring_sync.objects.resolution.Merge attribute) core CREATE (calendaring_sync.objects.edit.EditKind attribute) create() (calendaring_sync.replica.Replica method) cursor D DEFAULT_TIMEOUT (in module calendaring_sync.constants) DELETE (calendaring_sync.objects.edit.EditKind attribute) Delete (class in calendaring_sync.objects.resolution) delete() (calendaring_sync.replica.Replica method) delete_record() (calendaring_sync.store.base.StateStore method) delete_scope() (calendaring_sync.store.base.StateStore method) DELETED_LOCALLY (calendaring_sync.objects.conflict.ConflictKind attribute) discard() (calendaring_sync.replica.Replica method) drop drop_scope() (calendaring_sync.replica.Replica method) DroppedScope (class in calendaring_sync.objects.dropped_scope) DuplicateObjectError E edit (calendaring_sync.objects.record.Record attribute) EditKind (class in calendaring_sync.objects.edit) EditRefusedError entries() (calendaring_sync.store.base.StateStore method) F feed_bounds() (calendaring_sync.store.base.StateStore method) feed_head() (calendaring_sync.replica.Replica method) FEED_PAGE_SIZE (in module calendaring_sync.constants) FeedEntry (class in calendaring_sync.objects.feed) FeedEntryKind (class in calendaring_sync.objects.feed) find_by_logical_key() (calendaring_sync.replica.Replica method) (calendaring_sync.store.base.StateStore method) find_record() (calendaring_sync.replica.Replica method) (calendaring_sync.store.base.StateStore method) fingerprint (calendaring_sync.objects.change.Changed attribute) (calendaring_sync.objects.edit.LocalEdit attribute) (calendaring_sync.objects.record.Record attribute) (calendaring_sync.objects.resolution.Merge attribute) fingerprint scheme fingerprint_scheme (calendaring_sync.objects.scope.Scope attribute) from_change() (calendaring_sync.objects.conflict.Conflict class method) full listing full_listing (calendaring_sync.objects.change_set.ChangeSet attribute) G get_record() (calendaring_sync.store.base.StateStore method) get_scope() (calendaring_sync.store.base.StateStore method) Gone (class in calendaring_sync.objects.push) H holder (calendaring_sync.objects.conflict.Conflict attribute) (calendaring_sync.objects.push.LogicalKeyTaken attribute) I id (calendaring_sync.objects.scope.Scope attribute) IDLE (calendaring_sync.replica.SessionState attribute) in flight IN_FLIGHT (calendaring_sync.objects.record.RecordState attribute) incremental change set ingest ingest() (calendaring_sync.replica.Session method) INGESTED (calendaring_sync.replica.SessionState attribute) INGESTING (calendaring_sync.replica.SessionState attribute) insert_record() (calendaring_sync.store.base.StateStore method) is_create (calendaring_sync.objects.record.Record property) ISSUES_URL (in module calendaring_sync.constants) K KeepEdit (class in calendaring_sync.objects.resolution) kind (calendaring_sync.objects.conflict.Conflict attribute) (calendaring_sync.objects.edit.LocalEdit attribute) (calendaring_sync.objects.feed.FeedEntry attribute) known_versions() (calendaring_sync.replica.Replica method) L last_entry (calendaring_sync.objects.record.Record attribute) last_full_listing_at (calendaring_sync.objects.scope.Scope attribute) last_sync_at (calendaring_sync.objects.scope.Scope attribute) listing_token (calendaring_sync.objects.scope.Scope attribute) local edit local key local_key (calendaring_sync.objects.feed.FeedEntry attribute) (calendaring_sync.objects.record.Record attribute) LocalEdit (class in calendaring_sync.objects.edit) logical key logical_key (calendaring_sync.objects.change.Changed attribute) (calendaring_sync.objects.edit.LocalEdit attribute) (calendaring_sync.objects.record.Record attribute) (calendaring_sync.objects.resolution.Merge attribute) LOGICAL_KEY_TAKEN (calendaring_sync.objects.conflict.ConflictKind attribute) LogicalKeyTaken (class in calendaring_sync.objects.push) M media_type (calendaring_sync.objects.scope.Scope attribute) MemoryStore (class in calendaring_sync.store.memory) Merge (class in calendaring_sync.objects.resolution) module calendaring_sync.constants calendaring_sync.error calendaring_sync.objects.change calendaring_sync.objects.change_set calendaring_sync.objects.conflict calendaring_sync.objects.dropped_scope calendaring_sync.objects.edit calendaring_sync.objects.feed calendaring_sync.objects.push calendaring_sync.objects.record calendaring_sync.objects.resolution calendaring_sync.objects.scope calendaring_sync.replica calendaring_sync.store.base calendaring_sync.store.memory calendaring_sync.store.sqlite N number (calendaring_sync.objects.feed.FeedEntry attribute) O object object id object_id (calendaring_sync.objects.feed.FeedEntry attribute) (calendaring_sync.objects.push.Applied attribute) (calendaring_sync.objects.record.Record attribute) OpenConflictError opened_at (calendaring_sync.objects.conflict.Conflict attribute) P page pending (calendaring_sync.objects.dropped_scope.DroppedScope attribute) PENDING (calendaring_sync.objects.record.RecordState attribute) pending edit PendingEditError purge purge() (calendaring_sync.replica.Replica method) push PUSH_FAILED (calendaring_sync.objects.feed.FeedEntryKind attribute) PUSHED (calendaring_sync.objects.feed.FeedEntryKind attribute) PushInFlightError PUSHING (calendaring_sync.replica.SessionState attribute) PushOutcome (in module calendaring_sync.objects.push) put_scope() (calendaring_sync.store.base.StateStore method) Python Enhancement Proposals PEP 561 R read_feed() (calendaring_sync.replica.Replica method) record Record (class in calendaring_sync.objects.record) record() (calendaring_sync.replica.Replica method) recorded_at (calendaring_sync.objects.edit.LocalEdit attribute) records() (calendaring_sync.replica.Replica method) RecordState (class in calendaring_sync.objects.record) RecordValueError Rejected (class in calendaring_sync.objects.push) remote_containers (calendaring_sync.objects.conflict.Conflict attribute) remote_content (calendaring_sync.objects.conflict.Conflict attribute) remote_fingerprint (calendaring_sync.objects.conflict.Conflict attribute) remote_logical_key (calendaring_sync.objects.conflict.Conflict attribute) remote_version (calendaring_sync.objects.conflict.Conflict attribute) REMOVED (calendaring_sync.objects.feed.FeedEntryKind attribute) (calendaring_sync.objects.record.RecordState attribute) Removed (class in calendaring_sync.objects.change) removed_records() (calendaring_sync.store.base.StateStore method) REMOVED_REMOTELY (calendaring_sync.objects.conflict.ConflictKind attribute) RemovedRecordError Replica (class in calendaring_sync.replica) reset reset() (calendaring_sync.replica.Replica method) Resolution (in module calendaring_sync.objects.resolution) resolve() (calendaring_sync.replica.Replica method) resolve_conflicts() (calendaring_sync.replica.Replica method) resolver RFC RFC 3253 Section 3.1.5 RFC 3986 Section 2.3 RFC 4791 Section 1.3 RFC 4791 Section 5.3.2.1, [1] RFC 4791 Section 5.3.4, [1] RFC 4791 Section 7.9, [1], [2] RFC 4918 Section 10.2 RFC 4918 Section 15.6 RFC 4918 Section 9.1 RFC 5545 Section 3.1.4, [1] RFC 5545 Section 3.3.10 RFC 5545 Section 3.7.3 RFC 5545 Section 3.8.4.7 RFC 5545 Section 3.8.7.2 RFC 5545 Section 3.8.7.3 RFC 6578 RFC 6578 Section 3.1 RFC 6578 Section 3.2, [1], [2], [3], [4], [5] RFC 6578 Section 3.4 RFC 6578 Section 3.5.1 RFC 6578 Section 3.5.2 RFC 6578 Section 3.6, [1], [2] RFC 6578 Section 3.7, [1] RFC 6578 Section 4, [1] RFC 6638 Section 3.2.4.1 RFC 8620 Section 1.6.3 RFC 8620 Section 5.1 RFC 8620 Section 5.2, [1], [2], [3] RFC 8620 Section 5.3, [1] RFC 8984 Section 4.1.4 RFC 9110 Section 13.1.1, [1] RFC 9110 Section 13.1.2, [1] RFC 9110 Section 8.8.3.2 S SCHEMA_VERSION (in module calendaring_sync.constants) scope (calendaring_sync.objects.change_set.ChangeSet attribute) (calendaring_sync.objects.dropped_scope.DroppedScope attribute) (calendaring_sync.objects.feed.FeedEntry attribute) (calendaring_sync.objects.record.Record attribute) Scope (class in calendaring_sync.objects.scope) scope() (calendaring_sync.replica.Replica method) SCOPE_DROPPED (calendaring_sync.objects.feed.FeedEntryKind attribute) scope_id (calendaring_sync.replica.Session property) scope_records() (calendaring_sync.store.base.StateStore method) ScopeMismatchError scopes() (calendaring_sync.replica.Replica method) (calendaring_sync.store.base.StateStore method) server_version (calendaring_sync.objects.record.Record property) session Session (class in calendaring_sync.replica) session() (calendaring_sync.replica.Replica method) SessionError SessionState (class in calendaring_sync.replica) settle() (calendaring_sync.replica.Session method) since (calendaring_sync.objects.change_set.ChangeSet attribute) SQLiteStore (class in calendaring_sync.store.sqlite) StaleChangeSetError StaleConflictError state (calendaring_sync.objects.record.Record attribute) (calendaring_sync.replica.Session property) StateStore (class in calendaring_sync.store.base) store StoreBusyError StoreError StoreVersionError sync token SYNCED (calendaring_sync.objects.record.RecordState attribute) synced content synced_at (calendaring_sync.objects.record.Record attribute) T TakeServer (class in calendaring_sync.objects.resolution) to_push() (calendaring_sync.replica.Session method) token (calendaring_sync.objects.change_set.ChangeSet attribute) (calendaring_sync.objects.scope.Scope attribute) transaction() (calendaring_sync.store.base.StateStore method) TransactionError TransactionPermissionError TransactionRequiredError trim_entries() (calendaring_sync.store.base.StateStore method) trim_feed() (calendaring_sync.replica.Replica method) TrimmedFeedError truncated (calendaring_sync.objects.change_set.ChangeSet attribute) truncated page U UID Unchanged (class in calendaring_sync.objects.change) UnexpectedStoreError Unknown (class in calendaring_sync.objects.push) UnknownHolderError UnknownRecordError UnknownScopeError update_record() (calendaring_sync.store.base.StateStore method) UpdateHolder (class in calendaring_sync.objects.resolution) V version (calendaring_sync.objects.change.Changed attribute) (calendaring_sync.objects.record.Record attribute)